47 lines
802 B
Nix
47 lines
802 B
Nix
{
|
|
inputs = {
|
|
nixpkgs.url = "github:nixos/nixpkgs/nixos-24.11";
|
|
crate2nix = {
|
|
url = "github:nix-community/crate2nix";
|
|
inputs.nixpkgs.follows = "nixpkgs";
|
|
};
|
|
};
|
|
|
|
nixConfig = {
|
|
allow-import-from-derivation = true;
|
|
};
|
|
|
|
outputs =
|
|
{
|
|
self,
|
|
crate2nix,
|
|
nixpkgs,
|
|
}:
|
|
let
|
|
system = "x86_64-linux";
|
|
pkgs = nixpkgs.legacyPackages.${system};
|
|
in
|
|
{
|
|
devShells.${system}.default = pkgs.mkShell {
|
|
packages = with pkgs; [
|
|
cargo
|
|
clippy
|
|
diesel-cli
|
|
emscripten
|
|
rustc
|
|
rustfmt
|
|
leptosfmt
|
|
rust-analyzer
|
|
trunk
|
|
wasm-pack
|
|
nodePackages.npm
|
|
|
|
lld
|
|
|
|
pkg-config
|
|
openssl
|
|
];
|
|
};
|
|
};
|
|
}
|