adventofcode-2023/flake.nix

20 lines
381 B
Nix

{
description = "Advent of Code 2023 repo";
inputs = {
nixpkgs.url = "github:nixos/nixpkgs/nixos-23.11";
};
outputs = {nixpkgs, ...}: let
system = "x86_64-linux";
pkgs = nixpkgs.legacyPackages.${system};
in {
devShells.${system}.default = pkgs.mkShell {
packages = with pkgs; [
kotlin
kotlin-language-server
];
};
};
}